Forum Discussion

dragonflymr's avatar
Icon for Cirrostratus rankCirrostratus
May 17, 2017

Reselect member with new port


I am not sure if my rule is broken or there is some bug in v11.2.0

I have VS IP:8888 with pool containing members set to All ports IP:0 but backed server is listening on port 443.

I need to change port from 8888 to 443 when connecting to backed server.

I tired this iRule but always getting error like that:

TCL error: /Common/http_to_https_one_vs - failed to find pool member (line 1) invoked from within "pool LAMP_110_all_pl member 443"




    pool LAMP_110_all_pl member 443


I tried putting above command in HTTP_REQUEST event but error is the same. Tried to use /Common/LAMP_110_all_pl as well, no difference.

However everything works OK when I switch to below code


when LB_SELECTED {  
    LB::reselect node 443


I would prefer to use first one as second one seems to be messing up with LB a bit. By that I mean that before LB::reselect is used, LB::server name is returning

/Common/PoolName 0

after reselect just 443

and in node command (don't know if it is realted to LB::reselect node as well) there is note:

Since statistics and health monitoring are tied to pool membership, node status and statistics for this connection will not be available.

So why pool LAMP_110_all_pl member 443 is returning error?


No RepliesBe the first to reply