Forum Discussion

Subrun's avatar
Icon for Cirrostratus rankCirrostratus
Jun 22, 2023

Idle Timeout not reflecting when Changed from Default 300 secs.

I changed Idle Timeout form 300 secs to a bigger value mainly followed below steps , but when traffic is following through F5 , user is seeing timeout in around 5 mins when they check directly from Pool member it is more than 5 mins. 

What wrong I am doing  ? How can I validate this ?

Creating a new protocol profile that uses a different timeout value

  1. Log in to the Configuration utility.
  2. Navigate to Local Traffic > Profiles.
  3. Click the Protocol tab.
  4. Click the relevant protocol profile. For example, FastL4.
  5. Click Create.
  6. Type a name for the new profile.
  7. For Parent Profile click the parent profile you want to use.
  8. For Idle Timeout, select the Custom check box.
  9. Type the new Idle Timeout value, in seconds.
  10. Click Finished.
  11. Navigate to Local Traffic > Virtual Servers.
  12. Click the virtual server to modify.
  13. For Configuration, click Advanced.

    Note: For BIG-IP 11.5.0 and later versions, clicking Advanced is no longer necessary.

  14. In the Protocol Profile (Client) box, click the new profile you created.
  15. Click Update.

    The virtual server now uses the new idle timeout setting.




4 Replies

    • Subrun's avatar
      Icon for Cirrostratus rankCirrostratus


      My Keep Alive Interval - is higher than Idle Timeout , since idle time out should trigger before

      • JRahm's avatar
        Icon for Admin rankAdmin

        Hi Subrun if you take a verbose tcpdump capture w/ the F5 flags enabled, you'll be able to see the reset reason on the packets in the capture, if it is the big-ip that is resetting it and not an upstream devices that has shorter timers.